IMPORTANT NOTICE: Due to the COVID related issues your order may take longer than usual to arrive.   Read More
We have detected you're not on the correct site for the car you have selected! Click the green button below to go to the correct site.
Select your car: 
BMW Mini Cooper
Select
 

 DINAN Elite on a 2020 Cooper S?

 Created by: Jfhall27
Orig. Posting Date User Name Edit Date
May 4, 2020 04:06AM kenatminimania  
May 3, 2020 12:30PM Jfhall27  
   Forum Width:     Forum Type: 

 Posted: May 4, 2020 04:06AM
Total posts: 1970
Last post: Nov 17, 2020
Member since:Dec 29, 2004
Cars in Garage: 1
Photos: 9
WorkBench Posts: 0
Quote:
Originally Posted by Jfhall27

Looking to see if anybody has installed the DINAN Elite tuner (D440-0052) in a 2020 Cooper S. Their website says it’s compatible with the 2020 so we picked one up. Install was very easy. When I took it out for a ride all was fine de the first few minutes. I then jumped on the gas and the CEL popped on, I got a drivetrain malfunction error in the screen and the car went into a limp mode. I restarted it and it seemed to run fine but the CEL was still on.

I’m able to reproduce the issue pretty consistently. The error codes that come up are:

 

U0603

P0193

P0192

P0238

P0108

 

I went ahead and plugged in the bypass module that comes with the DINAN kit and the car runs fine. The CEL also went off.

Dinan technical support is probably the best and quickest source to resolve this... It sounds like their software might need a slight adjustment for the 2020 lci engines.

 Posted: May 3, 2020 12:30PM
Total posts: 1
Last post: May 3, 2020
Member since:May 3, 2020
Cars in Garage: 0
Photos: 0
WorkBench Posts: 0

Looking to see if anybody has installed the DINAN Elite tuner (D440-0052) in a 2020 Cooper S. Their website says it’s compatible with the 2020 so we picked one up. Install was very easy. When I took it out for a ride all was fine de the first few minutes. I then jumped on the gas and the CEL popped on, I got a drivetrain malfunction error in the screen and the car went into a limp mode. I restarted it and it seemed to run fine but the CEL was still on.

I’m able to reproduce the issue pretty consistently. The error codes that come up are:

 

U0603

P0193

P0192

P0238

P0108

 

I went ahead and plugged in the bypass module that comes with the DINAN kit and the car runs fine. The CEL also went off.