New MINI Carbon Parts
We have detected you're not on the correct site for the car you have selected! Click the green button below to go to the correct site.
Select your car: 
BMW Mini Cooper
Select
 

 Confusing Oil Service Light

 Created by: minimontero
   Forum Width:     Forum Type: 

 Posted: Aug 7, 2019 12:16PM
Total posts: 1896
Last post: Aug 10, 2020
Member since:Dec 29, 2004
Cars in Garage: 1
Photos: 9
WorkBench Posts: 0
Quote:
Originally Posted by minimontero
So I have a 2015 Mini Cooper F56. Recently, the oil service light came on, but it’s been 3K or so miles since my last oil change, and I regularly change it at around 5000 miles if not before then. The alert I get says the service is overdue, but that my service date is 02/2020?? Obviously it is not 2020. I ended up resetting it just to not hear that nuisance of an alert, so it is now 08/2020 (120,000mi). Should I be worried? I have less than 60k on my car currently and the system says my oil levels are ok. Is this a common problem?
Was the oil service reminder reset at each oil change?

 Posted: Aug 5, 2019 08:00PM
Total posts: 2
Last post: Aug 5, 2019
Member since:Aug 5, 2019
Cars in Garage: 0
Photos: 0
WorkBench Posts: 0
  • Oops. Sorry.

 Posted: Aug 5, 2019 07:36PM
Total posts: 3919
Last post: Oct 29, 2019
Member since:Oct 4, 2013
Cars in Garage: 0
Photos: 0
WorkBench Posts: 0
just wait until you see the BILL at your local BMW dealer..  btw. this is mostly a classic mini site..

 Posted: Aug 5, 2019 03:20PM
Total posts: 2
Last post: Aug 5, 2019
Member since:Aug 5, 2019
Cars in Garage: 0
Photos: 0
WorkBench Posts: 0
So I have a 2015 Mini Cooper F56. Recently, the oil service light came on, but it’s been 3K or so miles since my last oil change, and I regularly change it at around 5000 miles if not before then. The alert I get says the service is overdue, but that my service date is 02/2020?? Obviously it is not 2020. I ended up resetting it just to not hear that nuisance of an alert, so it is now 08/2020 (120,000mi). Should I be worried? I have less than 60k on my car currently and the system says my oil levels are ok. Is this a common problem?